Best Practices RSS feed for this section

How to deal with changing USB drive letters easily

A lot of customers ask how they can define a job so that it always copies to or from a USB drive, even if that drive’s letter changes. For example, on one day, your external hard drive might be drive F: and on another day, Windows changes it to drive G:.

The solution is to change the “Base Path” for the external drive in the profile. Instead of the drive letter, type the volume label (volume name). For example, if your drive is named MyUSBDrive, then you would type MyUSBDrive:\FolderA instead of F:\FolderA.

Amazon Glacier Backup

Since version 6.20, Syncovery can upload files to Amazon Glacier. To set up Glacier as the destination, click on the Internet button for the right-hand side and choose Glacier as the Internet Protocol.

Amazon Glacier is intended for long term archiving and backup with the expectation that most operations are uploads and not downloads. Downloads should be a rare exception, since they can be extremely slow. To download a file, Syncovery needs to initiate a job with Amazon Glacier, and even with small files, it takes at least three hours for Amazon Glacier to retrieve the item. The same is true for file listings. Therefore, Glacier cannot be used for two-way synchronizations. It is intended only for backing up and archiving.

Please be aware that there is a download fee from Amazon if you download more than 5% of your data per month (or something like that). It seems that in some special cases, the download fee can be extreme. If you intend to make a full backup and restore for testing, please read the fee schedule closely, and also read articles such as this one:
Is There a Landmine Hidden in Amazon’s Glacier?


Two methods to use Glacier

  • Choose S3 inside our software, and use a lifecycle rule in S3 to move files to Glacier to reduce costs. See the Amazon Web Services Blog
  • Choose Glacier directly in our software. The rest of this article describes this method.

Because there is no quick way to get a file listing from Glacier, Syncovery maintains a local database with the information of all the files on Glacier. This database is automatically maintained and it is independent from the checkmark “Cache Destination File List”. Therefore, with Glacier, there is no need to use the caching option. The local databases used for Glacier are separate for each vault, but shared among all profiles. When you create a new profile that accesses an existing vault, it will alraedy know the vault contents, if the vault has been used on the same machine.

Glacier also cannot rename items which have been uploaded. When you rename or move files on the local side, they have to be uploaded again.

In version 6.20, the download process is still inefficient if you need to download many files. It will initiate the download job for each file and wait for it to complete, then download the file, and then proceed to the next file. You can specify a number of files to copy in parallel in this fashion (on the Files tab sheet), but the limit is 30. So, you can download up to 30 files in 3 to 5 hours, but downloading 300 files will take 30 to 50 hours. This limitation will be removed in a future update.

In light of this, if there is a chance you will need a complete restore, it may make sense to use “Zip Packages” with many files per zip archive, instead of uploading individual files.

This information will be updated as support for Glacier is optimized and more experiences are made with Amazon’s new service.

Mountain Lion Compatibility

A Mountain Lion compatible update of Syncovery is now available. The version number must be 6.03 or higher.

To be able to continue using your old configuration and profiles, please use at least version 6.04 or higher.

The migration wizard should appear automatically, or you can invoke it via the File menu. You can also manually import config files via the File menu.

Since version 6.04, no special action is required any more to migrate your settings.

Creating Profile Groups


You can create profile groups by naming your profiles as shown in this example:

Backup Home
Backup Office
Backup Music

This will create the group “Backup” containing these three profiles because the first word in the profile names is identical.

Then you can easily select them or choose them with checkmarks (Windows only) and start them all at once.

Be sure to check out the right-click menu that you get in the Profile Overview. It contains options to start the profiles in various ways, such as:

  • Run in Attended Mode
  • Run in Unattended Mode
  • Run in Background

How can I make sure the scheduler starts automatically?

Method 1 (using the Background Scheduler – recommended)

The background scheduler is configured to start automatically when you save a profile that uses a schedule. You can also check the Auto-Start option on the “Tools and Settings” menu from the Scheduler tab sheet.

Method 2 (using the Syncovery Service – Windows only)

The main advantage of the Syncovery Service is that it runs even when no user is logged on. However, it is more difficult to set up and since it runs as an invisible service, it is less intuitive. For example, it can’t prompt the user in case an FTP password has changed, or when there is a SmartTracking conflict.

Using the service can fix some “Access Denied” problems because it normally runs with more privileges than the main program GUI.

You will find more information on the service here.

Copying open / locked files, such as Outlook or SQL databases


  • On Windows, the software can copy locked files by using the Volume Shadow Copy Service that is integrated into Windows. This feature is automatically used when needed. It can be configured on the tab sheet “File Access”.

  • On Macintosh or Linux, open files can always be copied unless “Database-safe mode” is chosen on the File Access tab sheet.

Fixing a “cannot access left / right path” error

  • If the scheduler is running as a service, it does not have network access without extra steps. There are two requirements for network access:
  • First, if running as a service, it must be given a log on account. This is done when clicking on the Install… button on the Scheduler tab sheet to install the service. To change the log on account, please uninstall and then re-install the service. Make sure that you specify a user account where you know that Windows Explorer has access to the volumes that you need. Choose an account that has network access without Windows Explorer asking for a password for the network drive. Windows Explorer should have already stored the password.
  • Second, network volumes must be specified using a UNC path such as \\servername\sharename\foldername rather than a mapped drive letter.
  • If this is not sufficient, you can provide a username and password for the network resource in each profile. Use this setting on the Job tab sheet in the profile:
    Network Connections… However, in many cases this is not needed. Rather than specifying the full path for the network connection, you can also try specifying just \\servername.
  • For more details, please see Running the scheduler as a service.

Modification dates of files are not retained. What can be done?


This problem usually occurs when using Internet Protocols such as FTP, WebDAV, as well as Cloud Services such as Amazon S3 and Google Docs. The problem does not occur with Windows networking (CIFS/Samba), SSH/SFTP, and many modern FTP or even some WebDAV servers.

FTP and WebDAV servers traditionally use the current system time for all incoming files. So the timestamp on the FTP server becomes different from the Last Modified time on your computer. In some cases, this is not a problem (for example if you only copy files to the FTP server). However, if you need to copy bidirectionally or really need to preserve the timestamp, here’s what can be done.

The best thing to do would be to install a more modern FTP server software that is able to keep the timestamps, for example the very latest Windows Server 2008R2 version, or Gene6 FTP Server from www.gene6.com, or switching to a different protocol, such as SSH/SFTP.

If the server software can’t be replaced, you could use Filename Encoding to retain the timestamps on the FTP server. You’ll find that option on the Versioning tab sheet. Filename Encoding will modify the filenames by adding the date and time to them, so you can only use it if it’s OK that the filenames look encoded on the server.

If filename encoding can’t be used and you need to do a bidirectional synchronization, there is still another option. You can use SmartTracking, which can remember the timestamp that the server assigns to the files when they were uploaded. That way, it can recognize if the files have been changed or not, even if the timestamp is not identical to the one on your computer. For this, please choose the SmartTracking operating mode on click the Configure button. Go to the Options tab sheet and choose “Detect Unchanged Files” for the online side. Uncheck the other option “Also Ignore File Sizes” which rarely needed.

If you have already uploaded files and their timestamps do not match, you can use this SmartTracking method (as described above) to handle the problem. First you need to let the program build the database so that it remembers the existing timestamps. Do this by starting the profile manually and choosing “Show: Unaffected” in the Sync Preview so that it doesn’t copy any files but adds them all to the database.

Building the file list takes too long. How to make it faster?


There are various ways to speed up building the file listing.

  • Use at least version 7.20, which can generate a fast, multi-threaded file listing. If necessary, you can increase the number of folder scanning threads on the Performance tab sheet on the Program Settings dialog, or on the Job tab sheet in the profile.

  • Make sure you haven’t chosen “Binary Comparison” on the tab sheet Comparison->More.

  • Make sure you don’t use any unncessary logging. Especially “With Timing Info” or “File List Building Details” or “Internet Protocol Logging” dramatically slow down the listing process.

  • If you are using “Process Security and Shares” on the Special tab sheet, make sure that in the pop-up dialog that appears when you click on that checkbox, you have not chosen “Update existing files” because that will be slow. If you must update existing items, make sure the setting is “Update Existing Items: Folders (and files will inherit)”.

  • If you are using FTP, you can choose the recursive FTP Listing Command LIST -alR on the second tab sheet of the Internet dialog. If you are using SSH/SFTP and the server is a Linux/Unix type of server, you can try the “Recursive Listing” checkmark.

  • You can install the Syncovery Remote Service on the other computer to generate the file list remotely. The Remote Service is available for Windows and Mac.

  • If you have a one-way sync and you are just mirroring or backing up, you may be able to use the option “Cache Destination File List” from the Special tab sheet. However this option means that any changes on the destination by another person or program are not seen by the software, because it always remembers the last state in its cache and never looks at the destination folders again.
  • You can use Real Time Synchronization which simply copies new and changed files rather than comparing the two folder structures. However, it is recommended to also schedule a full run regularly to catch any files that may have been missed in real time. Also, Real Time changes are only detected on local drives and via LAN or VPN. Changes are not detected via FTP, WebDAV and so forth. Some computers or network devices may not be sending real-time notifications over the LAN.

  • If you only need to copy new and modified files to the destination and never delete any files from the destination, you could turn off scanning the destination completely (on the Files tab sheet), and under General Filters, use the two Archive Flag checkmarks (available on Windows only). On the first run, this will mean copying all files because the Archive flags are still set for all files. You can avoid that by adding a fixed date/time filter such as Date later than XX/YY/ZZZZ.

  • If the Archive Flags cannot be used, you could still turn off scanning the destination and use a File Age filter such as “less than 1 days” old.

How can I synchronize file deletions?

Important note for all sync modes regarding deletions: if you want to run the profile in unattended mode, for example by running the scheduler, then you need to also give it explicit permission to delete the files. To do so, please edit the profile in Advanced Mode, go to the Safety->Unattended tab sheet and make sure that deletions are enabled. You may also want to remove the last checkmark, “Enable Special Safety Warnings”, because these can prevent deletions from being carried out.

  • If one side is always the “model” and the other side is always the “mirror”, i.e. you are copying only in one direction, then you can use Exact Mirror mode to synchronize deletions.

  • If you are working on both sides, and copying files in both directions, then you must use SmartTracking to detect and handle file deletions.

    When you choose it, you will see a separate dialog with a few options where you can specify how certain situations should be handled. SmartTracking can recognize these situations by keeping a database and comparing the current state of your folders with the last state stored in the database.

    You can set it to move the file into a folder for deleted files whenever it recognizes a deletion. This works similar to a recycle bin. It won’t physically delete the file for safety reasons. You need to choose a folder for deleted files (one for each side of the sync). This folder should by outside of the hierarchy that you are syncing.

    For SmartTracking to work, you always need to use the same profile for syncing the same folders, because the database is specific to each profile, and the program must use the same database always. In addition, you need to start the profile on the same computer each time.

    Deletions will be recognized starting with the second synchronization after you turn on SmartTracking. During the first run, the database is built.

  • Note that the Real-Time mode (when using “Process Each File Event Individually”) has its own setting for deletions. On the other hand, when you are using the real-time mode “Process Complete Folders”, then deletions are carried out according to the paragraphs above.

    To enable deletions to work in real time individual event mode, please edit the profile in Advanced Mode. Go to the “Schedule” settings category and to the Monitoring/Real-Time tab sheet. Click on the checkmark “Real-Time Synchronization”. A dialog will pop up where you need to make sure that the checkmark “Process deletions when running in real-time” is chosen, and that the Safety Delay matches your requirements. Many users will just want to set it to 0.