Getting Access Denied Error to USB

English Support for Syncovery on Linux etc.
Post Reply
RTAdmin
Posts: 2
Joined: Tue Jun 18, 2024 6:02 pm

Getting Access Denied Error to USB

Post by RTAdmin »

Hi,

I'm evaluating Syncovery. I have a number of Windows boxes using Syncback. It looks lIke Syncovery would be a good replacement since I'm starting to use Linux Mint boxes as lower powered backup controllers.

I'm trying to mirror a NAS share to a locally mounted USB drive in Linux Mint.

I can successfully mirror NAS to NAS, so no permissions problems there.

I get a failure when running to the USB:
Error accessing folder /media/rtadmin/TData/BU/Active: Permission Denied

What am I doing wrong? I navigated to that location with the GUI, and that's the string it returns, so I expect the location is correct.

Thanks,

Rick

tobias
Posts: 1744
Joined: Tue Mar 31, 2020 7:37 pm

Re: Getting Access Denied Error to USB

Post by tobias »

Hello,
thanks for your question!

The first step would be to post the complete log file. Near the top you will find the user account that Syncovery runs as.

And then you could enter this command in a Terminal to see the folder permissions:
ls -al /media/rtadmin/TData/BU/Active

RTAdmin
Posts: 2
Joined: Tue Jun 18, 2024 6:02 pm

Re: Getting Access Denied Error to USB

Post by RTAdmin »

OK, I've changed a bunch of settings, and so my problem has changed.

The access denied has gone away.

However, If I run the job to the USB as a mounted drive, it now writes to the mount point directory, not to the large USB drive I have attached. If I run the job, I run out of disk space in my file system, and if I examine the USB drive, nothing is being written there. I've changed the mount point location, but it persists.

I have a feeling this is simple, but I'm at a loss.

Rick

tobias
Posts: 1744
Joined: Tue Mar 31, 2020 7:37 pm

Re: Getting Access Denied Error to USB

Post by tobias »

Hello,
this happens when an external drive is not mounted. The dummy mount folder may still exists, but it's empty.

So you need to access the drive in a file manager first and verify the mount point again, which may vary.

In Syncovery, you can make sure it doesn't write to empty folders by choosing the following checkmark in the profile, on the "Job" tab sheet:

Run only if neither side is empty

Post Reply