Email Notification error on QNAP

English Support for Syncovery on Linux etc.
Post Reply
Systeq
Posts: 11
Joined: Thu Oct 08, 2020 10:19 am

Email Notification error on QNAP

Post by Systeq »

Currently running Syncovery 9.47g on the latest QNAP firmware.

Jobs are running ok, however I can't get email notifications to work. I've configured the email/SMTP settings with 2 different known working configurations, and in both cases when I send a test email I get:

An Exception occurred:Synapse TCP/IP Socket error -2: error:1408F10B:SSL routines:ssl3_get_record:wrong version number@ 00000000007599E9Application Error At 00000000007599E9 on 06/22/2022 12:19:06 Exception ESynapseError: Synapse TCP/IP Socket error -2: error:1408F10B:SSL routines:ssl3_get_record:wrong version number Executable: /share/CACHEDEV1_DATA/.qpkg/SyncoveryCL/SyncoveryCL Reporting Thread ID: 139881438238464 Size: 26186040 (64-bit) Exception in WebServ, sendtestmail.php, params=token=MDYvMjIvMjAyMiAxMjowNTo1OA== Parameter: start Parameter: /INI=/share/CACHEDEV1_DATA/.qpkg/SyncoveryCL/Syncovery.cfg Client Pipes: 0, Threads: 0 Server Pipes: 2, Threads: 4 Stack Trace ----------- Exception class: ESynapseError Stacktrace: $00000000007599E9 $0000000000762CD8 $0000000000E2EC7E $0000000000E2F042 $0000000000E3129A $0000000000E31AA7 $0000000000D290A5 $00000000005158CF $0000000001362542 $0000000001363587 $0000000001237E85 $00000000012313BA $0000000001230F43 $000000000122F9C5 $000000000043F388 -----------


It appears to be reporting a Wrong Version number for something, but I'm not entirely sure what.

Systeq
Posts: 11
Joined: Thu Oct 08, 2020 10:19 am

Re: Email Notification error on QNAP

Post by Systeq »

Ok so it appears tp be TLS that isn't working. Setting the SMTP Configuration to "Insecure" works. Is there some additional configuration needed for TLS?

tobias
Posts: 1047
Joined: Tue Mar 31, 2020 7:37 pm

Re: Email Notification error on QNAP

Post by tobias »

Hi,
I think you need to play with the TLS version (try 1.2) and also the "Explicit TLS" checkmark.

It might not work with all SMTP servers. I am not sure if TLS 1.3 is actually implemented, so if the server requires that, it may not work.

Systeq
Posts: 11
Joined: Thu Oct 08, 2020 10:19 am

Re: Email Notification error on QNAP

Post by Systeq »

Thanks Tobias, I'll have a play with it and see what I can come up with.

I configured it in exactly the same way I have a working Windows version of Syncovery configured, so I know those settings do work, but there may be a different configuration that works also. At least I can now receive notifications using the "insecure" method, so that removes any urgency to get TLS working.

Post Reply