Dashboard often hangs with "loading" after clicking OK on "edit profile"

English Support for Syncovery on Linux etc.
Post Reply
vance
Posts: 17
Joined: Tue Aug 24, 2021 10:28 pm

Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by vance »

Hi... I have a fresh install of Syncovery (v9.38) running on a fresh Linux install, and I often have the dashboard freeze up in a "loading" hourglass. It's happened to me about four times since last night, within less than an hour of total usage. I know the last two of them happened after I hit "OK" on "edit profile". The main screen behind is is mostly white (no profiles are shown).

To fix this, I've tried reloading the page, as well as some of the commands shown https://www.syncovery.com/download/linux/. Neither solves it. Rebooting does. In response to those commands, the service responds with text that suggest it thinks everything is OK (attached).

Any thoughts on what could be causing this? This is Ubuntu-Cinnamon Remix, based on Ubuntu 21.04.
Attachments
SyncoveryCL.png
SyncoveryCL.png (359.67 KiB) Viewed 516 times

tobias
Posts: 711
Joined: Tue Mar 31, 2020 7:37 pm

Re: Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by tobias »

Hello,
apparently the Syncovery service is in an unworkable state when this happens. You should be able to restart it with:
SyncoveryCL stop
sudo killall SyncoveryCL
sudo killall -9 SyncoveryCL

and finally
SyncoveryCL start

Can you check if there is a log file called SyncoveryCL_Exceptions.log in the Logs folder? If so, can you send it to support@syncovery.com?

Also to analyze this more, it might help if you could run SyncoveryCL not as a service but as a normal program in a terminal, so you can see its output.

To do this, instead of SyncoveryCL start, just enter:
SyncoveryCL

If there isn't already a SyncoveryCL main process running, this will run it and provide the web GUI etc, and you can see some status info in the terminal.

I hope we can work on this together to find the root cause.

vance
Posts: 17
Joined: Tue Aug 24, 2021 10:28 pm

Re: Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by vance »

Thank you -- yes, that kills the process and lets me restart without rebooting. That's a big help.

I've emailed the log offline.

I'm running the app out of the terminal now, per your instruction. The problem hasn't happened today -- I would've expected it to, given its frequency yesterday -- but if it does, I'll let you know what it shows. I'm happy to help dig into it, given your good support.

tobias
Posts: 711
Joined: Tue Mar 31, 2020 7:37 pm

Re: Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by tobias »

Hello,
some general info, if it happens again.

To be able to analyze the GUI status, can you go to the Program Settings dialog, tab sheet Advanced, and choose
X Enable status web pages for each SyncoveryCL process

And then when you see again that the profile list cannot be loaded or refreshed, please open port 8998, which should show a status page, and send me that. On this status page, please then also click on "Click here to see the thread report" and send me that too.

Then I should be able to identify a problem.

tobias
Posts: 711
Joined: Tue Mar 31, 2020 7:37 pm

Re: Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by tobias »

Hello,
can you try the new Linux version 9.39f? I fixed a few thread safety issues that may have caused this, and removed a locking mechanism that is no longer needed.

vance
Posts: 17
Joined: Tue Aug 24, 2021 10:28 pm

Re: Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by vance »

I don't remember anymore what changed, but this specific problem hasn't recurred since my last post in this thread.

The tips you gave in this thread, about managing the background process and GUI, have been very useful in other situations.

I did now upgrade to v9.39f.

tobias
Posts: 711
Joined: Tue Mar 31, 2020 7:37 pm

Re: Dashboard often hangs with "loading" after clicking OK on "edit profile"

Post by tobias »

Thanks for the info!

Post Reply