Page 1 of 1

Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 4:28 pm
by paqman
I have Syncovery installed on a raspberry pi, trying to configure it to send backups to my Glacier vault. Just having trouble figuring out how to configure it. My Glacier vault name is test, and they give me an ARN, but that's about it. I have my IAM access ID and secret key obviously, and I can select my region, but just not sure what Syncovery wants in the "Vault" and "Folder" Fields. No combination of my ARN or vault name seem to be working. Here is what is wanted for the configs:
syncovery.jpg
syncovery.jpg (77.84 KiB) Viewed 411 times
The error it gives me when I try to "browse" the vault is a connection problem, "could not load SSL library. at 00CC8164". Then it says could not browse this storage. But obviously I need to have the right address in that field first, which I'm not sure what to put. I've tried multiple variations of my ARN, but nothing seems to work. Any ideas how I'm supposed to configure this?

Re: Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 4:44 pm
by tobias
Hello,
OK this is an SSL library problem, not a configuration problem. Syncovery can't find the OpenSSL/LibreSSL libraries. Unfortunately the library names change often between Linux distributions, so that symbolic links may be necessary to add in the lib folder.

Did you try the latest Syncovery 9.38e? How did you install it?

Which Linux distribution or image did you install?

Re: Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 5:29 pm
by paqman
Yeah, that makes sense. I had considered that, but wasn't sure that was the main problem. Yeah I just installed this yesterday, and so I used the latest 9.38e. I'm actually running OMV on this particular build, so I installed the debian package, Syncovery-9.38e-armhf.deb. This is kind of a POC box at the moment. (I'm planning on building a new Plex/Backup server, running it on Ubuntu, so I would eventually be doing it on that)

So yeah I'm hunting around for where the libraries might be. I didn't enable SSL/TLS or anything yet, if that makes a difference. I'm a unix administrator, you'd think I would know how to find these libraries lol.

Re: Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 6:07 pm
by tobias
Hello,
in the simplest case, you would have these files:

/lib/libcrypto.so
/lib/libssl.so

These are usually symbolic links to versioned library file names.

They can also be in a subfolder, for example
/lib/arm-linux-gnueabihf/libcrypto.so
/lib/arm-linux-gnueabihf/libssl.so

Which OMV version do you have exactly?

Re: Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 6:49 pm
by paqman
tobias wrote:
Thu Aug 05, 2021 6:07 pm
Hello,
in the simplest case, you would have these files:

/lib/libcrypto.so
/lib/libssl.so

These are usually symbolic links to versioned library file names.

They can also be in a subfolder, for example
/lib/arm-linux-gnueabihf/libcrypto.so
/lib/arm-linux-gnueabihf/libssl.so

Which OMV version do you have exactly?
Ah, yes, thanks. I do see these:
/usr/lib/arm-linux-gnueabihf/libcrypto.so.1.1
/usr/lib/arm-linux-gnueabihf/libk5crypto.so.3 -> libk5crypto.so.3.1
/usr/lib/arm-linux-gnueabihf/libk5crypteo.so.3.1
/usr/lib/arm-linux-gnueabihf/libssl.so.1.1

So I'm assuming I need to link from somewhere in /usr/lib to one of these? I'm running OMV 5.4.0-1 fyi.

Re: Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 7:36 pm
by tobias
Hello,
yes, for example in a shell prompt, you can do:

cd /usr/lib/arm-linux-gnueabihf

sudo ln -s libcrypto.so.1.1 libcrypto.so
sudo ln -s libssl.so.1.1 libssl.so

Re: Configuring Syncovery for Glacier

Posted: Thu Aug 05, 2021 8:07 pm
by paqman
tobias wrote:
Thu Aug 05, 2021 7:36 pm
Hello,
yes, for example in a shell prompt, you can do:

cd /usr/lib/arm-linux-gnueabihf

sudo ln -s libcrypto.so.1.1 libcrypto.so
sudo ln -s libssl.so.1.1 libssl.so
That did it, thanks! Apparently, I don't have to put in the ARN at all. I just need my access ID, secret key, and region in there, and apparently that's all it needs to find my vault. Thank you very much