brand new install, does not preserve dates

English Support for Syncovery on Apple Computers.
Post Reply
rmichelena
Posts: 7
Joined: Wed Oct 19, 2022 8:36 pm

brand new install, does not preserve dates

Post by rmichelena »

Just got my new shiny MacBook Air M2, macOS Monterey 12.6, and installed Syncovery 9.48i(413) from scratch without importing any config.
I have a Time Machine backup of my previous Mac but I didn't want to restore from it, just some folders.

So I launched Syncovery, created a profile to copy everything from the Time Machine's latest backup "Desktop" folder to my new Mac's "Desktop" folder.
Run it, and all files copied have "created" and "modified" dates of today. It didn't preserve the dates.

What could have go wrong? I didn't make any fancy mods to the profile, just left it as it is by default. I did notice that by default the profile does not have the "use mac API copyfile function", which is weird since (also by default) Syncovery's preferences have that enabled.
I also checked that the profile does not have the "copied files receive current time as timestamp" option.
The folders do have correct timestamps, though.

The fact that the origin is a Time Machine volume should not matter, as it's just an HFS+ volume with hardlinks.
I don't believe that the destination being (as it comes now by default in new Macs) an APFS volume, or that it has FileVault encryption enabled, should make any difference either...

best regards,

Roberto Michelena

tobias
Posts: 1199
Joined: Tue Mar 31, 2020 7:37 pm

Re: brand new install, does not preserve dates

Post by tobias »

Hello,
can you make another test with additional logging?

On the Program Settings dialog, tab sheet "Logs", please choose:
X Time Stamp Setting Details

rmichelena
Posts: 7
Joined: Wed Oct 19, 2022 8:36 pm

Re: brand new install, does not preserve dates

Post by rmichelena »

Done with Logs.

The relevant parts copied below.

Roberto

--------

Left Side Volume Name: LaCie
Right Side Volume Name: Macintosh HD
Checking if permissions are enabled: diskutil info "/Volumes/LaCie"
Owners: Disabled (Case-sensitive Journaled HFS+)
Checking if permissions are enabled: diskutil info "/"
Owners: Enabled (APFS)

Copying Direction : Left To Right

.....

Main Copying Phase Started At 20/10/22 19:16:21

Calling SetDstTimesAttrsSecurity for API copied file

Set Dest Times (Mode=1), Name=/Users/roberto/Downloads/(30) LinkedIn.mp4

Calling SetAttr in SetDstTimesAttrsSecurity
Setting kFSCatInfoSettableInfo for /Users/roberto/Downloads/(30) LinkedIn.mp4
Setting time for /Users/roberto/Downloads/(30) LinkedIn.mp4, FSMakePathRef result=0 isFolder=0
Setting /Users/roberto/Downloads/(30) LinkedIn.mp4 to 8/11/19 14:36:23
chk: 8/11/19 14:36:23
Setting times for /Users/roberto/Downloads/(30) LinkedIn.mp4 via utime
buf.modtime=1573223783 = 8/11/19 14:36:23 = 8/11/19 14:36:23
Error setting timestamp for /Users/roberto/Downloads/(30) LinkedIn.mp4 errno=1
Unknown Unix Error Code 5
VerifyDestTimestamp, name=/Users/roberto/Downloads/(30) LinkedIn.mp4
Dest found, mod time=20/10/22 19:16:22 src mod time=8/11/19 09:36:23 crea time=20/10/22 19:16:21 src crea time=8/11/19 09:36:16
Times are different
SetReadWriteAttr for /Users/roberto/Downloads/(30) LinkedIn.mp4
Calling SetTimes again
Setting time for /Users/roberto/Downloads/(30) LinkedIn.mp4, FSMakePathRef result=0 isFolder=0
Setting /Users/roberto/Downloads/(30) LinkedIn.mp4 to 8/11/19 14:36:23
chk: 8/11/19 14:36:23
Setting times for /Users/roberto/Downloads/(30) LinkedIn.mp4 via utime
buf.modtime=1573223783 = 8/11/19 14:36:23 = 8/11/19 14:36:23
Error setting timestamp for /Users/roberto/Downloads/(30) LinkedIn.mp4 errno=1
Unable to set timestamp for /Users/roberto/Downloads/(30) LinkedIn.mp4, Error Code=5, Msg=Permission Denied
Undo SetReadWriteAttr for /Users/roberto/Downloads/(30) LinkedIn.mp4
Setting kFSCatInfoSettableInfo for /Users/roberto/Downloads/(30) LinkedIn.mp4
VerifyDestTimestamp, name=/Users/roberto/Downloads/(30) LinkedIn.mp4
Dest found, mod time=20/10/22 19:16:22 src mod time=8/11/19 09:36:23 crea time=20/10/22 19:16:21 src crea time=8/11/19 09:36:16
Times are different
SetReadWriteAttr for /Users/roberto/Downloads/(30) LinkedIn.mp4
Calling SetTimes again
Setting time for /Users/roberto/Downloads/(30) LinkedIn.mp4, FSMakePathRef result=0 isFolder=0
Setting /Users/roberto/Downloads/(30) LinkedIn.mp4 to 8/11/19 14:36:23
chk: 8/11/19 14:36:23
Setting times for /Users/roberto/Downloads/(30) LinkedIn.mp4 via utime
buf.modtime=1573223783 = 8/11/19 14:36:23 = 8/11/19 14:36:23
Error setting timestamp for /Users/roberto/Downloads/(30) LinkedIn.mp4 errno=1
Unable to set timestamp for /Users/roberto/Downloads/(30) LinkedIn.mp4, Error Code=5, Msg=Permission Denied
Undo SetReadWriteAttr for /Users/roberto/Downloads/(30) LinkedIn.mp4
Setting kFSCatInfoSettableInfo for /Users/roberto/Downloads/(30) LinkedIn.mp4
Copy L->R /Volumes/LaCie/Backups.backupdb/Macbook RMQ/2022-05-27-074032/Macintosh HD - Data/Users/roberto/Downloads/(30) LinkedIn.mp4 (13.1MB)

rmichelena
Posts: 7
Joined: Wed Oct 19, 2022 8:36 pm

Re: brand new install, does not preserve dates

Post by rmichelena »

After the run that produced the log in the previous message (and again failed to set dates correctly), I tried running as root, and it did work setting the dates correctly.

I also tried (non-root) with a different destination volume, which was also APFS but owners disabled (external drive). Same result, does not set dates.
I then tried with an HFS+ destination volume (external drive). Same result.

So no matter the source and destination volumes, it's unable to set dates unless it's running as root.

Roberto

tobias
Posts: 1199
Joined: Tue Mar 31, 2020 7:37 pm

Re: brand new install, does not preserve dates

Post by tobias »

Many thanks, that seems to be an entirely new problem, possibly caused by the latest macOS version. I will check if anything can be done.

rmichelena
Posts: 7
Joined: Wed Oct 19, 2022 8:36 pm

Re: brand new install, does not preserve dates

Post by rmichelena »

So any luck fixing this for v10 ?

tobias
Posts: 1199
Joined: Tue Mar 31, 2020 7:37 pm

Re: brand new install, does not preserve dates

Post by tobias »

Hello,
I have tested Syncovey on macOS Ventura and could not produce the problem here. Everything works as expected. I also do not have any report from any other user of this problem. Right now I don't know what to do. Something on your system prevents the timestamps from being set.

I am working on Syncovery 10 for macOS now and will think about what we can do.

Post Reply