Delete older backups not working on versions?

English Support for Syncovery on Windows.
Post Reply
Giuse
Posts: 11
Joined: Thu May 25, 2023 10:26 pm

Delete older backups not working on versions?

Post by Giuse »

Hi Tobias, I am making some experiments waiting for your reply on viewtopic.php?t=705, to fully test "cleaner" jobs but found some weird behavior.
The purpose of this test is to delete version files that haven't be accessed in the past X days: I created a profile with Exact Mirror mode, source is an empty folder and destination is the "Older" folder where versions are moved to.
Now these are the results:
  • Exact Mirror Settings: Remove Files that dont match filter = NO, Age Filter = over X days, filter by last access => NO file is considered, the preview shows NO file, neither selecting "Show All" - this seems to be a bug since version files with last access over X days do exist.
  • Exact Mirror Settings: Remove Files that dont match filter = NO, Age Filter = less than X days, filter by last access => files that are "young" are deleted - that is correct (even if not the target behavior).
  • Exact Mirror Settings: Remove Files that dont match filter = YES, Age Filter = over than X days, filter by last access => ALL files are deleted, even those that have last access timestamp less than X days - that seems to me a bug
  • Exact Mirror Settings: Remove Files that dont match filter = YES, Age Filter = less than X days, filter by last access => ALL files are deleted, even those that have last access timestamp older than X days - that seems to me not correct
Can you have a look on this?
thanks a lot

Giuse

tobias
Posts: 1723
Joined: Tue Mar 31, 2020 7:37 pm

Re: Delete older backups not working on versions?

Post by tobias »

Hi,
thanks for the observations. I will look into it. But I think it's not worth it to implement such tricky workarounds. I will add the missing option soon.

Giuse
Posts: 11
Joined: Thu May 25, 2023 10:26 pm

Re: Delete older backups not working on versions?

Post by Giuse »

Thanks, apart from the new option, I think there is some bug in the filter age, maybe only on last access date, I haven't thoroughly tested the other types of time stamps. Cheers

tobias
Posts: 1723
Joined: Tue Mar 31, 2020 7:37 pm

Re: Delete older backups not working on versions?

Post by tobias »

Hello,
there is no bug. But the filters are taken into consideration for both sides, and if only one side matches, then the file is included.

Post Reply