Slow upload to S3 on 9.36

English Support for Syncovery on Windows.
Post Reply
noname
Posts: 1
Joined: Sun Jun 06, 2021 12:38 am

Slow upload to S3 on 9.36

Post by noname »

I just upgraded to 9 from the latest build on 8 since I was seeing spiky upload to S3 where it would jump to a 150-200 Mbps, then down to 0 for a few seconds, repeat. Upgrading to 9 fixed the spiky upload, but it has made the speed much worse. The remaining estimate to complete the backup on 8 was an hour, whereas the estimate on 9 has been sitting at 9 hours for the last 3 hours. I'm sitting at a steady 15-20Mbps upload now whereas if I upload a single file to s3 I get closer to 60Mbps.

Any settings I can try to mess with to fix this? I have cloud threads per file set at 100, and concurrent files set at 25. None of my drives are at their limits, nor the CPU. I've also tried disabling the default limits in the performance tab, but that didn't make a difference.

edit: I wasn't sure if this was a Windows issue or an S3 issue so I just stuck it here
edit2: one other relevant detail is that I'm encrypting/compressing the files, but given that the speed was much higher on 8 I'm not sure how much that affects things.

tobias
Posts: 591
Joined: Tue Mar 31, 2020 7:37 pm

Re: Slow upload to S3 on 9.36

Post by tobias »

You are probably using too many threads. Cloud threads per file should be between 3 and 5. I also don't think it's good to upload more than 12 files in parallel. Although likely possible.

To optimize upload speed with compression and encryption, please make sure you use the Sz file format and choose the encrypion level "Super Fast".

Could you send a log file from V8 and one from V9 so I can compare if you are actually comparing a similar situation and similar settings with both versions?

To analyze speed in more detail, you could invoke an "Activity Report" and send it to support@syncovery.com. If the job runs in the foreground, this is done with Ctrl-F2. For background jobs, it's done by right-clicking the job and choosing "Diagnose Activity".

Post Reply