bug with the ETA shown in the app.

General Discussion in English
Post Reply
xxxliqu1dxxx
Posts: 8
Joined: Thu Jan 14, 2021 5:47 pm

bug with the ETA shown in the app.

Post by xxxliqu1dxxx »

Just upgraded from Syncovery 8.x to 9.38k and I think there's a bug with the ETA shown in the app.

When running tasks in background, the ETA updates at the beginning but then stops updating and stays the same - It's been showing this for hours now:
Elapsed: 02:01:56 Rate: 21.78 MB/sec ETA: 00:53:20 -- That Elapsed moves correctly, but the ETA does not - it is stuck on this.

Here's a second job, same issue:
Elapsed: 02:05:26 Rate: 20.97 MB/sec ETA: 02:27:30 --- stuck on 02:27:30

This issues seems present for both the Application in Profile Overview and when showing detailed progress or results in browser per job.

Hoping this is a known issue and will be resolved later, or if I am the first reporting it - you're welcome and I look forward to it being resolved.

Thanks!

tobias
Posts: 678
Joined: Tue Mar 31, 2020 7:37 pm

Re: bug with the ETA shown in the app.

Post by tobias »

Hello,
are you sure the jobs are still progressing? You can check if they're hung by right-clicking and choosing "Show detailed progress or results in browser".

No, it is not a known issue.

xxxliqu1dxxx
Posts: 8
Joined: Thu Jan 14, 2021 5:47 pm

Re: bug with the ETA shown in the app.

Post by xxxliqu1dxxx »

Yes the jobs are progressing and they do complete successfully. Only the display / visual indication of the ETA seems to be broken.

tobias
Posts: 678
Joined: Tue Mar 31, 2020 7:37 pm

Re: bug with the ETA shown in the app.

Post by tobias »

Thanks, I will look into it.

AJSchmidt
Posts: 1
Joined: Sun Sep 26, 2021 7:02 pm

Re: bug with the ETA shown in the app.

Post by AJSchmidt »

My system is experiencing the same problem (Windows 10, Syncovery 9.39b).

The sync session has been progressing for hours and the ETA display has not updated,
while the File#, Elapsed, Rate, GB and % figures continue to update once per second.

"File #7026 of 7081 Elapsed: 03:24:12 Rate: 74.62 MB/sec ETA: 03:38:30"
"790 GB of 928 GB (85.16%)"


P.S. The advise ("You can check if they're hung by right-clicking and choosing "Show detailed progress or results in browser") does not seem to be available on my system. Right-clicking produces a reaction only in the progress window's title area, and that dialog offers only to Move, Minimize, or Close the window.

tobias
Posts: 678
Joined: Tue Mar 31, 2020 7:37 pm

Re: bug with the ETA shown in the app.

Post by tobias »

Hello,
thanks, I will look into it.

When jobs run in the foreground, you can invoke "Diagnose Activity" with Ctrl-F2. But it's not relevant for this problem.

tobias
Posts: 678
Joined: Tue Mar 31, 2020 7:37 pm

Re: bug with the ETA shown in the app.

Post by tobias »

Hello,
the new version 9.39c now has a new ETA algorithm. Can you try it?

If there are still problems, it's now possible to log details about ETA calculations.

You could also look in the log files for any error messages.

Post Reply