OneDrive funktioniert nicht

German Support for Syncovery on Linux etc.
Daniel
Posts: 13
Joined: Wed Jun 03, 2020 7:03 am

OneDrive funktioniert nicht

Post by Daniel »

Leider funktioniert die OneDrive Anbindung per "OneDrvNew" nicht.
Wenn ich einen neuen Auftrag anlege, dann auf Internet drücke und versuche ein Verzeichnis zu durchsuchen passiert das:

Code: Select all

Click here to authorize with the cloud service
*Klick* Auth in OneDrive

Code: Select all

You have successfully authorized your software. You can close this window now.
Es passiert lange nichts
Dann das kleine Fenster per x schließen
Nochmal drücken, dann kommt

Code: Select all

Listing is being prepared
10 Minuten nichts, dann timeout

Code: Select all

ERROR: Connection problem: ext://OneDrvNew: Internal Error: Timeout in EnterAuthSection (A)
Cannot browse this storage.
Mit Häkchen "Changes Based Listing (speeds up folder listing after the first run)" ausgeschaltet, auch schon versucht.


Ungefähr das Gleiche wenn man einfach versucht den Auftrag auszuführen
Lange passiert nichts, dann:

Code: Select all

ERROR: Cannot access ext://OneDrvNew/Anwendungen (Aborting (InCheckDriveConnected>0) at 0000000001297972)


tobias
Posts: 670
Joined: Tue Mar 31, 2020 7:37 pm

Re: OneDrive funktioniert nicht

Post by tobias »

Guten Tag,
ich habe es hier gerade einmal mit Version 9.38a probiert, und es funktioniert. Könnten Sie die neue Version testen?

Daniel
Posts: 13
Joined: Wed Jun 03, 2020 7:03 am

Re: OneDrive funktioniert nicht

Post by Daniel »

Diese Version habe ich bereits im Einsatz.
Es handelt sich dabei um einen docker container https://hub.docker.com/r/stefanruepp/syncoverycl

Könnte das der grund sein?

tobias
Posts: 670
Joined: Tue Mar 31, 2020 7:37 pm

Re: OneDrive funktioniert nicht

Post by tobias »

Die Logs sind aber von 9.37.

Ich denke, dass der Syncovery Dienst bloß neu gestartet werden muss, dann sollte es auch mit 9.37 gehen.

Daniel
Posts: 13
Joined: Wed Jun 03, 2020 7:03 am

Re: OneDrive funktioniert nicht

Post by Daniel »

Leider auch kein Erfolg, sowohl container Neustart als auch neustart von SyncoveryCL innerhalb des containers

tobias
Posts: 670
Joined: Tue Mar 31, 2020 7:37 pm

Re: OneDrive funktioniert nicht

Post by tobias »

Hi,
möglicherweise erlaubt der Container es Syncovery nicht, die notwendige temporäre Datei zu erstellen. Dann geht es nicht im Container, oder der Container muss geändert werden.

Eventuell mal den Pfad für temporäre Dateien bei den Program Settings überprüfen.

Daniel
Posts: 13
Joined: Wed Jun 03, 2020 7:03 am

Re: OneDrive funktioniert nicht

Post by Daniel »

Einstellung:

Code: Select all

Path For Temporary Files:  /tmp/
Inhalt während 'Listing is being prepared':

Code: Select all

drwxrwxrwx 2 root root 4096 Jul 12 22:26  ./
drwxr-xr-x 1 root root 4096 Jul 10 01:04  ../
srwxrwxrwx 1 root root    0 Jul 10 01:04  Syncovery.MainInterProcessPipe=
-rwxrwxrwx 1 root root    0 Jul 10 01:04  Syncovery.MainInterProcessPipe.mutex*
srwxrwxrwx 1 root root    0 Jul 10 01:04  Syncovery.MultiComPipe=
-rwxrwxrwx 1 root root    0 Jul 10 01:04  Syncovery.MultiComPipe.mutex*
srwxrwxrwx 1 root root    0 Jul 10 01:04  SyncoveryRemoteServiceCommPipe=
-rwxrwxrwx 1 root root    0 Jul 10 01:04  SyncoveryRemoteServiceCommPipe.mutex*
-rwxrwxrwx 1 root root    0 Jul 12 22:26 'syncovery$sffs$cloudauthmutex$onedrivenew'*
-rwxrwxrwx 1 root root    0 Jul 10 01:04 'syncovery$sffs$remoteservicemainmutex'*
-rwxrwxrwx 1 root root    0 Jul 10 01:04 'syncovery$sffs$schedulermutex'*
-rw-r--r-- 1 root root  752 Jul 10 01:04  syncoveryremserv.log

tobias
Posts: 670
Joined: Tue Mar 31, 2020 7:37 pm

Re: OneDrive funktioniert nicht

Post by tobias »

Hi,
also es geht hier um die Datei 'syncovery$sffs$cloudauthmutex$onedrivenew' - vielleicht hilft es, sie zu löschen?

tobias
Posts: 670
Joined: Tue Mar 31, 2020 7:37 pm

Re: OneDrive funktioniert nicht

Post by tobias »

Hi,
im allgemeinen bedeutet das Problem, dass zwei Threads gleichzeitig versuchen, die OneDrive-Authentication durchzuführen. Einer davon erreicht dann den Timeout. Die Frage ist also, wieso die Authentication zweimal gleichzeitig versucht wird.

Eine Ursache könnten zwei Profile sein, oder dass man es bei der Bearbeitung im Web GUI versucht hat, und dann noch ein Profil gestartet hat.

Das Problem kann normalerweise durch einen Neustart des SyncoveryCL-Prozesses gelöst werden.

Post Reply